Plugin and Firmware Versions and Update Instructions

Mach4: 10284
Mach4 Build: 3804
MachMotion Build: 10400

*May require new MachMotion license if updating from previous build. 
MachMotion
Plugin: 1.0.10284.0
HiCON:
Plugin: 2.02.06
Firmware: 3.67
FPGA: 8ACE
Mach3
HiCON
Plugin: 1.36.6
Firmware: 2.42
FPGA: 8ACE
 
DSPMC
Plugin: 4.0.19
Firmware: 8.24
FPGA: E104
 
PoKeys
Plugin: 1.0.0.1

 

 

 
For the Interpreter 1000
 

Below are the steps that you would need to follow using the 
VSI Device Manager (*See notes below):
_____________________________________________________________________________
 
1. Close Mach or any application that communicates with the DSPMC. 
   Also stop all dspMacros (if there are any).
_____________________________________________________________________________

2. Program the new firmware version 8.00 (or greater) to the DSPMC and wait for it to complete.  If any error, retry programming without power cycle.  Once success go to next step.
_____________________________________________________________________________

3. CYCLE THE POWER ON YOUR DSPMC (unplug the power for 5 seconds). Using Soft-Reboot may not be reliable in 
   this situation, and could brick your unit.
_____________________________________________________________________________

4. Program FPGA version E104. Use the "FPGA Slow Prog" button at the bottom
   of the window. The DSPMC CPU LED will blink rapidly for the programming 
   process. Wait for the process to finish (the CPU LED should be in slow 
   blink indicating that it is currently in normal operation mode).
_____________________________________________________________________________

5. Update your plugin in the Mach3 plugins folder.
_____________________________________________________________________________

NOTE: Check your plugin config. Depending on your last plugin version, the encoder 
and I/O polarity may be reversed by this new update, so you may need to reconfigure 
them in mach3. 

NOTE: Also check the Control Output in the DSPMC plugin for each axis (should be DAC) as they may be switched to something else if updating from a very old plugin version.

NOTE: You may need to update VSI device manager as well. Particularly if the FPGA buttons are inactive.

 

Keywords: 7654

Back to top